BICS: Namibia Connectivity Issues

Incident Report for SIMcontrol

Resolved

This incident has been resolved.
Posted Mar 19, 2026 - 09:21 CAT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 19, 2026 - 09:09 CAT

Investigating

We are aware of BICS connectivity issues in Namibia. SIMs are not able to establish new connections.

BICS is aware and their engineers are investigating.
Posted Mar 18, 2026 - 08:54 CAT
This incident affected: 🇳🇦SIMcontrol Namibia (BICS Global Roaming) and 🇿🇦 SIMcontrol South Africa (BICS Global Roaming).