Issue with MTC recharges / balance checks

Incident Report for SIMcontrol

Resolved

The network has successfully identified the root cause and has implemented a full and permanent fix.

Our monitoring confirms that both recharges and balance checks are now consistently successful, and we are no longer observing any related failures. The issue is now resolved.
Posted Sep 24, 2025 - 10:26 CAT

Update

The network has implemented a temporary fix to restore the services while they continue to investigate the root cause of the issue.

As a result, balance checks and recharges have been successfully restored. We will continue to actively follow up with the network and will provide you with feedback as soon as their investigation is complete.
Posted Sep 23, 2025 - 16:06 CAT

Update

We are still actively engaged with the network regarding the ongoing intermittent issues with recharges and balance checks.

Please be assured that their team is continuing its investigation to pinpoint the root cause, and we are diligently following up for a definitive update.

We will provide new information as soon as it becomes available.
Posted Sep 23, 2025 - 12:04 CAT

Update

We're still observing intermittent failures with recharges and balance checks.

We're actively working with the network to identify the root cause and find a resolution.
Posted Sep 23, 2025 - 08:37 CAT

Update

We're now seeing some successful recharges and balance checks, though the issue is still intermittent.

We've relayed this information to the MTC network team, who are continuing to actively investigate and work on a full resolution.

We appreciate your patience and will provide another update as soon as we have more information.
Posted Sep 22, 2025 - 16:42 CAT

Update

MTC's technical teams are still actively investigating the root cause of the recharge and balance check failures, and are working to resolve them.

We will share another update as soon as we receive more information from the MTC team.
Posted Sep 22, 2025 - 15:35 CAT

Update

The mobile network is still investigating the issues with recharges and balance checks on the MTC network.

We'll provide a full update as soon as we have more information.
Posted Sep 22, 2025 - 13:21 CAT

Investigating

We're experiencing technical issues with recharges and balance checking on the MTC network. The mobile network has been notified, and they are busy investigating.
Posted Sep 22, 2025 - 12:13 CAT
This incident affected: 🇳🇦SIMcontrol Namibia (MTC - Balance Checks, MTC - Recharges) and 🇿🇦 SIMcontrol South Africa (MTC Namibia - Balance checks, MTC Namibia - Recharges).