Issue with Telkom recharges

Incident Report for SIMcontrol

Resolved

The issue affecting recharges on the Telkom network has been resolved. Successful recharge transactions are now being processed.
Posted Jul 25, 2025 - 12:32 CAT

Update

The mobile network is continuing its investigation into this issue. We will maintain active follow-up and provide further updates upon receipt.
Posted Jul 25, 2025 - 10:35 CAT

Investigating

We're experiencing technical issues with recharges on the Telkom network. The mobile network has been notified, and they are busy investigating.
Posted Jul 25, 2025 - 07:54 CAT
This incident affected: 🇿🇦 SIMcontrol South Africa (Telkom - Recharges).