Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 20, 2026 - 22:00 CAT
Scheduled
We will be performing some upgrades and maintenance at our Cape Town data centre. SIM connectivity will not be affected.
Users may experience a few minutes of downtime on the SIMcontrol front-end (website) - please refresh your page after a few minutes.
Maintenance Window: Wednesday 20 May 2026 @ 22h00 to Thursday 21 May 2026 @ 05h00
Posted May 19, 2026 - 09:28 CAT
This scheduled maintenance affected: 🇿🇦 SIMcontrol South Africa (SIMControl Platform), 🇰🇪 SIMcontrol Kenya (SIMcontrol Platform), and 🇳🇦SIMcontrol Namibia (SIMcontrol Platform).