MTN has resolved the recharge failure fault and we can see successful recharges processing again
Posted May 22, 2025 - 13:58 CAT
Update
MTN South Africa is still experiencing issues on recharges. We are seeing some recharges being processed successfully, while others are not. We will continue to monitor and update once resolved.
Posted May 22, 2025 - 13:20 CAT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 22, 2025 - 09:44 CAT
Investigating
We're experiencing technical issues with recharges on the MTN network. The mobile network has been notified, and they are busy investigating.
Posted May 22, 2025 - 09:21 CAT
This incident affected: 🇿🇦 SIMcontrol South Africa (MTN - Recharges).