Namibia Roaming - Intermittent connectivity

Incident Report for SIMcontrol

Resolved

Services have been restored.
Posted Jun 04, 2025 - 09:08 CAT

Identified

We have received several reports of data roaming issues in Namibia. We suspect this to be related to the WACS cable break off the Namibian coast (https://mybroadband.co.za/news/broadband/597399-major-undersea-internet-cable-serving-south-africa-offline.html).

We expect local networks to start rerouting internet data traffic to alternative backup links.
Posted Jun 04, 2025 - 06:48 CAT
This incident affected: 🇳🇦SIMcontrol Namibia (BICS Global Roaming) and 🇿🇦 SIMcontrol South Africa (BICS Global Roaming, Vodacom - Public APN).