Issue with Vodacom recharge

Incident Report for SIMcontrol

Resolved

This incident has been resolved.
Posted May 21, 2025 - 21:00 CAT

Monitoring

We can see successful recharges go through now on the Vodacom Network and awaiting network confirmation that fault has been resolved
Posted May 21, 2025 - 19:57 CAT

Update

Vodacom General Network Issue:
We have received reports that Vodacom have experienced a general core network issue.
They experienced a power failure at a key data center resulting in wide spread network issues.
Traffic has been restored, however there is still instability and high latency.
We are also unable to process any recharges (airtime or data) at this time.
Posted May 21, 2025 - 18:17 CAT

Identified

We're experiencing technical issues with recharges on the Vodacom network.
Vodacom has advised that they are busy investigating.
Posted May 21, 2025 - 18:12 CAT
This incident affected: 🇿🇦 SIMcontrol South Africa (Vodacom - Recharges).