MTC Namibia Balance Checks and Recharges

Incident Report for SIMcontrol

Resolved

MTC has resolved this issue. We will monitor, but hope it has been permanently resolved.
Posted May 13, 2026 - 16:29 CAT

Investigating

MTC Namibia is again experiencing issues with balance checking and data bundle recharges.
The network has been notified and they have confirmed that they are investigating.
Posted May 13, 2026 - 11:18 CAT
This incident affected: 🇳🇦SIMcontrol Namibia (MTC - Balance Checks, MTC - Recharges).