Degraded Performance: SIMcontrol Platform

Incident Report for SIMcontrol

Resolved

All website issues have now been resolved. If you still experience any issues please contact our support team (support@simcontrol.co.za). We apologies for the inconvenience caused by these intermittent issues.
Posted Jan 28, 2026 - 11:26 CAT

Update

We are continuing to monitor for any further issues.
Posted Jan 28, 2026 - 10:35 CAT

Monitoring

Most services are now fully restored. Remaining issues include adding new SIMs to the platform. Our engineers are attending to these.
Posted Jan 28, 2026 - 10:34 CAT

Update

Most website issues have been resolved. Remaining issues include adding new SIMs and API functionality, as well as manual recharges and balance checks on some SIM types. Our engineers are attending to these.
Posted Jan 28, 2026 - 09:19 CAT

Identified

Engineers have identified the problem and are presently implementing a fix.
Posted Jan 28, 2026 - 08:28 CAT

Investigating

We are currently experiencing intermittent issues on the SIMcontrol website. These include adding SIMs, manual balance checks, and assigning payments. Engineers are busy investigating. SIM connectivity is not affected.
Posted Jan 28, 2026 - 07:56 CAT
This incident affected: 🇿🇦 SIMcontrol South Africa (SIMControl Platform), 🇰🇪 SIMcontrol Kenya (SIMcontrol Platform), and 🇳🇦SIMcontrol Namibia (SIMcontrol Platform).