Issue with Vodacom recharges and balance checks

Incident Report for SIMcontrol

Resolved

The technical issues affecting Vodacom recharges and balance checks have been resolved by the mobile network, and the services are operating normally.
Posted Jul 09, 2026 - 06:48 CAT

Identified

The mobile network has identified the cause of the technical issues affecting Vodacom recharges and balance checks. Their teams are working on a fix.
Posted Jul 08, 2026 - 20:17 CAT

Investigating

We're experiencing technical issues with recharges and balance checking on the Vodacom network. The mobile network has been notified, and they are busy investigating.
Posted Jul 08, 2026 - 19:50 CAT
This incident affected: 🇿🇦 SIMcontrol South Africa (Vodacom - Balance Checks, Vodacom - Recharges).