Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 25, 2025 - 00:00 CAT
Scheduled
Please take note of a maintenance window scheduled for the following date and time: - Date: Thursday 25th September 2025 - Maintenance Window: 00:00 - 02:00 (SAST / GMT+2)
Purpose & Scope Of Works: MTN capacity upgrade
Services Affected: APN Traffic. MTN only (Vodacom not affected).
Connectivity Impact: No impact expected. Traffic will be rerouted through the CPT redundancy infrastructure during the maintenance period.
Posted Sep 18, 2025 - 15:33 CAT
This scheduled maintenance affected: 🇿🇦 SIMcontrol South Africa (Flickswitch APN).