MTN South Africa Balance and Recharge downtime

Incident Report for SIMcontrol

Resolved

Services have been restored by MTN, Balance checks and recharges are now working
Posted Jul 02, 2026 - 10:55 CAT

Identified

MTN is experiencing downtime on their core provisioning systems. Recharges and balance checks are affected. We will update this incident once the services have been restored by MTN
Posted Jul 02, 2026 - 10:15 CAT
This incident affected: 🇿🇦 SIMcontrol South Africa (MTN - Balance Checks, MTN - Recharges).