According to BICS's monitoring and statistics, traffic from Uganda has restored. This incident has been resolved.
Posted Jan 19, 2026 - 10:17 CAT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 14, 2026 - 17:23 CAT
Investigating
Please be informed that, according to the Uganda Communications Commission, data services in Uganda have been temporarily suspended due to election-related procedures.
Unfortunately, the networks have no influence over this situation. We will let you know as soon as new information becomes available on when connections will be restored.
Posted Jan 14, 2026 - 09:48 CAT
This incident affected: 🇳🇦SIMcontrol Namibia (BICS Global Roaming), 🇰🇪 SIMcontrol Kenya (BICS - Global Roaming), and 🇿🇦 SIMcontrol South Africa (BICS Global Roaming).