The network has resolved the issue, and successful balance checks are now being observed.
Posted Apr 04, 2025 - 09:56 CAT
Update
We are actively tracking the network provider's investigation and will provide updates as soon as they are available.
Posted Apr 04, 2025 - 09:08 CAT
Investigating
We're experiencing technical issues with balance checking on the Vodacom network. The mobile network has been notified and they are busy investigating.
Posted Apr 04, 2025 - 08:08 CAT
This incident affected: 🇿🇦 SIMcontrol South Africa (Vodacom - Balance Checks).