The scheduled maintenance was completed successfully. We have officially established peering with Cloudflare via NAPAfrica, and all systems are performing as expected.
Posted Feb 18, 2026 - 01:04 CAT
In progress
Scheduled maintenance is currently in progress.
Posted Feb 18, 2026 - 00:05 CAT
Scheduled
Please be aware of the following planned maintenance window:
Date: Tuesday, 17th February 2026 Maintenance Window: 17/02/2026 @ 11h55 (ZA / GMT+2) Scope of Work: APN Routing (Certain Destinations) Maintenance Description: This is a Firewall Routing Change Expected Downtime Duration: Possible Traffic Disruption (5Min) Services Affected: APN Routing (Certain Destinations) Service Impact: Possible Minor Disruption
Posted Feb 17, 2026 - 23:55 CAT
This scheduled maintenance affected: 🇿🇦 SIMcontrol South Africa (Flickswitch APN).