Balance checking and automated recharges are currently not working on MTC Namibia. SIM balances shown may be old. Our team is working with the network for them to resolve this.
You can however still process some manual recharges - please ensure SIMs have a airtime balance that equals at least the VAT amount of the bundle you are loading.
Posted May 08, 2026 - 08:53 CAT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 07, 2026 - 21:08 CAT
Identified
Manual and automatic usage rule Data bundle recharges have been disabled due to a misconfiguration on the network loading the incorrect bundle, we have notified the provider.
Posted May 07, 2026 - 09:30 CAT
This incident affected: 🇳🇦SIMcontrol Namibia (MTC - Recharges) and 🇿🇦 SIMcontrol South Africa (MTC Namibia - Recharges).