The mobile network has successfully identified and resolved the underlying issues that were causing balance check failures and preventing SIMs from being loaded onto SIMcontrol for Vodacom SIMs.
Posted Jul 25, 2025 - 15:24 CAT
Update
We are actively and persistently chasing the mobile network operator for progress on their investigation into these issues.
Updates will be provided as soon as more information is received.
Posted Jul 25, 2025 - 14:12 CAT
Update
The mobile network is continuing its investigation into these issues. We will maintain active follow-up and provide further updates upon receipt.
Posted Jul 25, 2025 - 12:08 CAT
Investigating
We're experiencing technical issues with balance checking on the Vodacom network and with the loading of Vodacom SIMs on SIMControl. The mobile network has been notified and they are busy investigating.
Posted Jul 25, 2025 - 10:39 CAT
This incident affected: 🇿🇦 SIMcontrol South Africa (Vodacom - Balance Checks).