Issue with MTC recharge / balance checks

Incident Report for SIMcontrol

Resolved

Balance checks and recharges continue to be successful, confirming that the issue is now resolved.
Posted Sep 15, 2025 - 18:05 CAT

Monitoring

We're now observing successful balance checks and recharges, and we'll continue to monitor them closely.
Posted Sep 15, 2025 - 16:30 CAT

Update

We have observed renewed failures in recharge transactions. The network has been notified and is currently investigating both the failed recharges and the ongoing balance check issues


We will provide feedback as soon as we have an update.
Posted Sep 15, 2025 - 15:00 CAT

Update

We have observed successful recharges; however, balance check issues are still being investigated by the network.

We will provide feedback as soon as we have an update.
Posted Sep 15, 2025 - 11:35 CAT

Update

The mobile network is still investigating the issues with recharges and balance checks on the MTC network.

We'll provide a full update as soon as we have more information.
Posted Sep 15, 2025 - 10:15 CAT

Investigating

We're experiencing technical issues with recharges and balance checking on the MTC network. The mobile network has been notified and they are busy investigating.
Posted Sep 15, 2025 - 08:40 CAT
This incident affected: 🇳🇦SIMcontrol Namibia (MTC - Balance Checks, MTC - Recharges) and 🇿🇦 SIMcontrol South Africa (MTC Namibia - Balance checks, MTC Namibia - Recharges).