Issue with MTN recharges

Incident Report for SIMcontrol

Resolved

We have monitored the stability of recharges, and it has returned to normal. Recharges are processing successfully.
Posted May 23, 2025 - 17:00 CAT

Update

A fix has been implemented and we are monitoring the results.
Posted May 23, 2025 - 16:30 CAT

Monitoring

A fix has been implemented and we are presently monitoring successful recharges.
Posted May 23, 2025 - 13:28 CAT

Identified

The issue has been identified and a fix is being implemented.
Posted May 23, 2025 - 09:07 CAT

Investigating

We're experiencing technical issues with recharges on the MTN network. The mobile network has been notified and they are busy investigating.
Posted May 23, 2025 - 07:43 CAT
This incident affected: 🇿🇦 SIMcontrol South Africa (MTN - Recharges).