TN Moile Namibia Connectivity Issues

Incident Report for SIMcontrol

Resolved

This incident has been resolved.
Posted Nov 21, 2025 - 12:39 CAT

Update

We are continuing to monitor for any further issues.
Posted Nov 21, 2025 - 06:28 CAT

Monitoring

BICS has advised that the connection success rate has returned to normal in Namibia and are currently monitoring
Posted Nov 21, 2025 - 06:00 CAT

Update

Update: We have confirmed that the connectivity issue in Namibia is not caused by BICS. TN Mobile is experiencing a country-wide data outage, which is preventing SIMs from establishing data sessions. The network team is working on restoring services, and we’ll share updates as they become available.
Posted Nov 20, 2025 - 11:16 CAT

Identified

The issue has been identified and a fix is being implemented.
Posted Nov 20, 2025 - 10:58 CAT

Investigating

We are aware of BICS connectivity issues in Namibia. SIMs are not able to establish connections.

We have raised this to the network and they are currently investigating.
Posted Nov 20, 2025 - 09:07 CAT
This incident affected: 🇳🇦SIMcontrol Namibia (BICS Global Roaming, TN Mobile) and 🇿🇦 SIMcontrol South Africa (BICS Global Roaming, TN Mobile Namibia).